Frame Relay - Detail and Configurations

Frame Relay

Frame Relay is a WAN (Wide Area Network) service which specify Physical and Data link Layer using the method of packet switching. Frame Relay is basically designed for ISDN (Integrated Service Digital Network) structure and in now a days it is also used in other structures of network.
ISP's (Internet Service Providers) uses Frame Relay for the data encryption and for VoFR (Voice over Frame Relay) between LAN's and WAN's connections. Each user configured with Frame Relay gets a private line over FR node. Networks configured with Frame Relay performs transmissions on continuously changing paths which are transparent for all end users by using WAN technologies.
FR is very cheap as compare to other WAN protocols that why FR is the priority of all the internet services provides (ISP's). FR in the beginning is used for error detection and as it detects the error it drops that packet.

PDU (Protocol Data Unit) of FR

Flag Field: Flag field creats a uniques sequence to identify the beggining and ending of frame with the help of syncronization process. Flag Field also ensure that the specific pattern is not repeated any where else in the frame with the help of stuffing and destuffing method.
Address Field: Address Field is used to specify the source and destination address. It consists of 2-3, 2-4, 2-5 octet depending upon the addresses used in network
Information/ Data Field: In information/ Data filed the main information/ data is encapsulated and the size of that field depends upon the bandwidth which is allocated to the network.
FCS (Frame Check Sequence) Field: FCS is used to check the sequence of frames send and received. It also keeps the record of sent and received frames so that if any frames drops due to error then transmission can be restarted from that frame and with the help of this wastage of bandwidth can be saved.

What are the advantages and disadvantages of Frame Relay?

Advantages

  • Frame Relay is cheaper than any other WAN protocol
  • Frame Relay creates a virtual circuit due to which physical looping is not required because each packet use virtual circuit for connections which are established
  • Frame Relay allows for the multiplexing of multiple PVC's using one physical circuit
  • Frame Relay allows switches supporting PVC routing in case of failure in circuit
  • Frame Relay is compatible with all old and new technologies
  • Frame Relay has more speed of transmission as compare to older WAN protocols

Disadvantages

  • Speed of Frame Relay is not enough for the protocols whose speed is more than 44.736 Mbps
  • Frame Relay allows frames of variable length
  • Delays will vary for all the users connected with it
  • Frame Relay is not suitable to send real time data which is voice calling, video calling and teleconferencing


Configurations

Frame Relay

Frame Relay - IP Address Table

FR Router

Router>enable
Router#configure terminal
Router(config)#hostname FR
FR(config)#enable secret class
FR(config)#line console 0
FR(config-line)#password cisco
FR(config-line)#login
FR(config-line)#exit
FR(config)#line vty 0 4
FR(config-line)#password cisco
FR(config-line)#login
FR(config-line)#exit

FR(config)# frame-relay switching
FR(config)# interface serial 0/0/0
FR(config-if)# encapsulation frame-relay
FR(config-if)# frame-relay intf-type dce
FR(config-if)# frame-relay route 103 interface s0/0/1 301
FR(config-if)# no shutdown
FR(config-if)# exit
FR(config)# interface serial 0/0/1
FR(config-if)# encapsulation frame-relay
FR(config-if)# frame-relay intf-type dce
FR(config-if)# frame-relay route 301 interface s0/0/0 103
FR(config-if)# no shutdown
FR(config-if)# exit

FR(config)# exit
FR# wr

R1 Router

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#enable secret class
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)# interface gigabitEthernet 0/0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# ipv6 address 2001:DB8:ACAD:A::1/64
R1(config-if)# ipv6 address FE80::1 link-local
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface serial 0/0/0
R1(config-if)# ip address 10.1.1.1 255.255.255.252
R1(config-if)# ipv6 address 2001:DB8:ACAD:B::1/64
R1(config-if)# ipv6 address FE80::1 link-local

R1(config-if)# encapsulation frame-relay
R1(config-if)# no frame-relay inverse-arp
R1(config-if)# frame-relay map ip 10.1.1.2 103 broadcast
R1(config-if)# frame-relay map ipv6 2001:db8:acad:b::3 103
R1(config-if)# frame-relay map ipv6 fe80::3 103 broadcast
R1(config-if)# frame-relay map ip 10.1.1.1 103
R1(config-if)# frame-relay map ipv6 2001:db8:acad:b::1 103
R1(config-if)# no shutdown
R1(config-if)# exit

!Configuration of EIGRP
R1(config)# ipv6 unicast-routing
R1(config)# router eigrp 1
R1(config-router)# no auto-summary
R1(config-router)# eigrp router-id 1.1.1.1
R1(config-router)# network 10.1.1.0 0.0.0.3
R1(config-router)# network 192.168.1.0
R1(config-router)# ipv6 router eigrp 1
R1(config-rtr)# router-id 1.1.1.1
R1(config-rtr)# no shutdown
R1(config-rtr)# interface g0/0
R1(config-if)# ipv6 eigrp 1
R1(config-if)# interface s0/0/0
R1(config-if)# ipv6 eigrp 1
R1(config-if)# exit

R1(config)# exit
R1# wr

R3 Router

Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#enable secret class
R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#exit
R3(config)#line vty 0 4
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#exit
R3(config)# interface gigabitEthernet 0/0
R3(config-if)# ip address 192.168.3.1 255.255.255.0
R3(config-if)# ipv6 address 2001:DB8:ACAD:C::3/64
R3(config-if)# ipv6 address FE80::3 link-local
R3(config-if)# no shutdown
R3(config-if)# exit
R3(config)# interface serial 0/0/1
R3(config-if)# ip address 10.1.1.2 255.255.255.252
R3(config-if)# ipv6 address 2001:DB8:ACAD:B::3/64
R3(config-if)# ipv6 address FE80::3 link-local

R3(config-if)# encapsulation frame-relay
R3(config-if)# no frame-relay inverse-arp
R3(config-if)# frame-relay map ip 10.1.1.1 301 broadcast
R3(config-if)# frame-relay map ipv6 2001:db8:acad:b::1 301
R3(config-if)# frame-relay map ipv6 fe80::1 301 broadcast
R3(config-if)# frame-relay map ip 10.1.1.2 301
R3(config-if)# frame-relay map ipv6 2001:db8:acad:b::3 301
R3(config-if)# no shutdown
R3(config-if)# exit

!Configuration of EIGRP
R3(config)# router eigrp 1
R3(config-router)# no auto-summary
R3(config-router)# eigrp router-id 3.3.3.3
R3(config-router)# network 10.1.1.0 0.0.0.3
R3(config-router)# network 192.168.3.0
R3(config-router)# ipv6 router eigrp 1
R3(config-rtr)# router-id 3.3.3.3
R3(config-rtr)# no shutdown
R3(config-rtr)# interface g0/0
R3(config-if)# ipv6 eigrp 1
R3(config-if)# interface s0/0/1
R3(config-if)# ipv6 eigrp 1
R3(config-if)# exit

R3(config)# exit
R3# wr

No comments:

Post a Comment