Wednesday 5 April 2017

Multiarea OSPF - Configuration of Multiarea OSPF

Multiarea OSPF

Multiarea OSPF is process in which networks are divided into sub domains/ areas. Router in each sub domain/ area contains the information about whole topology information. Each interface of router by default belongs to one area of OSPF.


Configurations of Multiarea OSPF

Multiarea OSPF
IP ADDRESS TABLE
DEVICEINTERFACEIP ADDRESSSUBNETMASK
R1 Lo0209.165.200.225 255.255.255.252
 Lo1 192.168.1.1 255.255.255.0
 Lo2192.168.2.1 255.255.255.0
 Serial 0/0/0 172.16.1.1 255.255.255.252
R2 Lo6 192.168.3.1 255.255.255.0
 serial 0/0/0 172.16.1.2 255.255.255.252
 serial 0/0/1 172.16.1.5 255.255.255.252
R3 Lo4 192.168.5.1 255.255.255.0
 Lo5 192.168.6.1 255.255.255.0
 serial 0/0/1 172.16.1.6 255.255.255.252

Scenario

OSPF (Open Shortest Path First) is an protocol for IP networks to perform routing over the network of more than 15 hop count, it is also known as open-standard link-state routing protocol. OSPFv2 is defined for IPv4 networks address, while OSPFv3 is defined for IPv6 networks address. OSPFv2 and OSPFv3 are completely isolated routing protocols which means that changes in OSPFv2 do not affect OSPFv3 routing, and vice versa. In this lab, we will configure multiarea OSPF to perform routing over the network having different networking running in it with different areas.

Note: The routers used with CCNA hands-on labs are Cisco 1941 Integrated Services Routers (ISRs) with Cisco IOS Release 15.2(4)M3 (universalk9 image). Other routers and Cisco IOS versions can be used. Depending on the model and Cisco IOS version, the commands available and output produced might vary from what is shown in the labs. Refer to the Router Interface Summary Table at the end of this lab for the correct interface identifiers.

Note: Make sure that the routers have been erased and have no startup configurations.

R1

Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#enable password cisco (Plain Text Password)
R1(config)#enable secret class (Enycrypted Password)
R1(config)#username TestRouter secret csico
R1(config)#ip domain-name cisco.com
R1(config)#crypto key generate rsa
(Set key between 360 - 2048)
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 4
R1(config-line)#transport input ssh
R1(config-line)#login local
R1(config-line)#exit


R1(config)#interface loopback 0
R1(config-if)#ip address 209.165.200.225 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 2
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 172.16.1.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit

! Configuration of Default route towards Internet
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback 0

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 1
R1(config-router)#network 192.168.2.0 0.0.0.255 area 1
R1(config-router)#network 172.16.1.0 0.0.0.3 area 0
R1(config-router)#log-adjacency-changes
R1(config-router)#default-information originate
R1(config-router)#exit


R1(config)#exit
R1#copy running-config startup-config




R2

Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#enable password cisco (Plain Text Password)
R2(config)#enable secret class (Enycrypted Password)
R2(config)#username TestRouter secret csico
R2(config)#ip domain-name cisco.com
R2(config)#crypto key generate rsa
(Set key between 360 - 2048)
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
R2(config)#line vty 0 4
R2(config-line)#transport input ssh
R2(config-line)#login local
R2(config-line)#exit

R2(config)#interface loopback 6
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 172.16.1.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/0/1
R2(config-if)#ip address 172.16.1.5 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit 

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.3.0 0.0.0.255 area 3
R2(config-router)#network 172.16.1.0 0.0.0.3 area 0
R2(config-router)#network 172.16.1.4 0.0.0.3 area 3
R2(config-router)#log-adjacency-changes
R2(config-router)#default-information originate
R2(config-router)#exit

R2(config)#exit
R2#copy running-config startup-config




R3

Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#enable password cisco (Plain Text Password)
R3(config)#enable secret class (Enycrypted Password)
R3(config)#username TestRouter secret csico
R3(config)#ip domain-name cisco.com
R3(config)#crypto key generate rsa
(Set key between 360 - 2048)
R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login
R3(config-line)#exit
R3(config)#line vty 0 4
R3(config-line)#transport input ssh
R3(config-line)#login local
R3(config-line)#exit

R3(config)#interface loopback 4
R3(config-if)#ip address 192.168.5.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 5
R3(config-if)#ip address 192.168.6.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface serial 0/0/1
R3(config-if)#ip address 172.16.1.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit 
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.5.0 0.0.0.255 area 3
R3(config-router)#network 192.168.6.0 0.0.0.255 area 3
R3(config-router)#network 172.16.1.4 0.0.0.3 area 3
R3(config-router)#log-adjacency-changes
R3(config-router)#default-information originate
R3(config-router)#exit

R3(config)#exit
R3#copy running-config startup-config

No comments:

Post a Comment