Point-to-Point Protocol (PPP)-Authentication & Configuration

Point-to-Point Protocol (PPP)

Point-to-Point Protocol (PPP) is layer 2 (Data Link Layer) protocol which is used to establish direct connection between two end users to transfer data securely. PPP connection is established between two routers without having any end device or any other networking device between them. PPP provides authentication of connection with encryption of data during transfer and compression of data.

PPP is used on different type of physical networks which includes networks with serial cables, networks with phone line, networks with fiber-optic links and many more. It is also used for internet access which is established between ISP and end user. ISP's use Point-to-Point protocol between them and their users because data packets sent or received by user can't travel on line of modem without any layer 2 protocol.

There are two types of PPP which are used by ISP's to connect their users with them
  • PPPoE (Point-to-Point Protocol over Ethernet)
  • PPPoA (Point-to-Point Protocol over ATM)
PPP is mostly used on data link layer for the connection using synchronous and asynchronous circuits. The main requirement for this protocol is duplex circuit.

PPP has two types of authentications
  • PAP (Password Authentication Protocol)
  • CHAP (Challenge Handshake Authentication Protocol)

PAP (Password Authentication Protocol)

PAP (Password Authentication Protocol) is an authentication protocol which is based on password to authenticate the users. Maximum number of remote servers of Network Operating Systems support PAP Authentication. PAP authentication is considered as week authentication because it transfer passwords over the networks without encryption.

How PAP works?

  • Username and Password is sent by source to destination
  • If username and password matches destination send acknowledgment of authentication
  • if username and password does not matches destination send acknowledgment of denial

CHAP (Challenge Handshake Authentication Protocol)

CHAP (Challenge Handshake Authentication Protocol) authenticate the user with the authentication entity which may be a ISP (Internet Service Provider). CHAP authenticate both sender and receiver with the secret of it's password while CHAP can't send or share password on the network on which it is configured. CHAP use Three way handshake to authenticate its user connected with it remotely.

Configuration of PPP

PPP
PPP IP Table

Branch1

Router>enable
Router#configure terminal
Router(Config)#hostname Branch1
Branch1(Config)#enable password cisco (Plain Text Password)
Branch1(config)#enable secret class (Encrypted Password)
Branch1(Config)#line console 0
Branch1(Config-line)#password cisco
Branch1(Config-line)#login
Branch1(Config-line)#exit
Branch1(Config)#line vty 0 4
Branch1(Config-line)#password cisco
Branch1(Config-line)#login
Branch1(Config-line)#exit
Branch1(config)#interface gigabiteathernet 0/1
Branch1(config-if)#ip address 192.168.1.1 255.255.255.0
Branch1(config-if)#no shutdown
Branch1(config-if)#exit
Branch1(config)#interface serial 0/0/0
Branch1(config-if)#ip address 10.1.1.1 255.255.255.252
Branch1(config-if)#encapsulation ppp
Branch1(config-if)#no shutdown
Branch1(config-if)#exit
Branch1(config)#router eigrp 1
Branch1(config-router)#network 192.168.1.0 0.0.0.255
Branch1(config-router)#network 10.1.1.0 0.0.0.3
Branch1(config-router)#exit
Branch1(config)#exit
Branch1#copy running-config startup-config

Central

Router>enable
Router#configure terminal
Router(Config)#hostname Central
Central(Config)#enable password cisco (Plain Text Password)
Central(config)#enable secret class (Encrypted Password)
Central(Config)#line console 0
Central(Config-line)#password cisco
Central(Config-line)#login
Central(Config-line)#exit
Central(Config)#line vty 0 4
Central(Config-line)#password cisco
Central(Config-line)#login
Central(Config-line)#exit
Central(config)#interface serial 0/0/0
Central(config-if)#ip address 10.1.1.2 255.255.255.252
Central(config-if)#encapsulation ppp
Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#interface serial 0/0/1
Central(config-if)#ip address 10.2.2.2 255.255.255.252
Central(config-if)#encapsulation ppp
Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#interface loopback 0
Central(config-if)#ip address 209.165.200.225 255.255.255.224
Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#router eigrp 1
Central(config-router)#network 10.1.1.0 0.0.0.3
Central(config-router)#network 10.2.2.0 0.0.0.3
Central(config-router)#network 209.165.200.224 0.0.0.3
Central(config-router)#exit
Central(config)#exit
Central#copy running-config startup-config

Branch3

Router>enable
Router#configure terminal
Router(Config)#hostname Branch3
Branch3(Config)#enable password cisco (Plain Text Password)
Branch3(config)#enable secret class (Encrypted Password)
Branch3(Config)#line console 0
Branch3(Config-line)#password cisco
Branch3(Config-line)#login
Branch3(Config-line)#exit
Branch3(Config)#line vty 0 4
Branch3(Config-line)#password cisco
Branch3(Config-line)#login
Branch3(Config-line)#exit
Branch3(config)#interface gigabiteathernet 0/1
Branch3(config-if)#ip address 192.168.3.1 255.255.255.0
Branch3(config-if)#no shutdown
Branch3(config-if)#exit
Branch3(config)#interface serial 0/0/1
Branch3(config-if)#ip address 10.2.2.1 255.255.255.252
Branch3(config-if)#encapsulation ppp
Branch3(config-if)#no shutdown
Branch3(config-if)#exit
Branch3(config)#router eigrp 1
Branch3(config-router)#network 192.168.3.0 0.0.0.255
Branch3(config-router)#network 10.2.2.0 0.0.0.3
Branch3(config-router)#exit
Branch3(config)#exit
Branch3#copy running-config startup-config

Configuration of PAP

 PPP
PPP IP Table

Branch1

Router>enable
Router#configure terminal
Router(Config)#hostname Branch1
Branch1(Config)#enable password cisco (Plain Text Password)
Branch1(config)#enable secret class (Encrypted Password)
Branch1(Config)#line console 0
Branch1(Config-line)#password cisco
Branch1(Config-line)#login
Branch1(Config-line)#exit
Branch1(Config)#line vty 0 4
Branch1(Config-line)#password cisco
Branch1(Config-line)#login
Branch1(Config-line)#exit
Branch1(Config)#username Central password cisco
Branch1(config)#interface gigabiteathernet 0/1
Branch1(config-if)#ip address 192.168.1.1 255.255.255.0
Branch1(config-if)#no shutdown
Branch1(config-if)#exit
Branch1(config)#interface serial 0/0/0
Branch1(config-if)#ip address 10.1.1.1 255.255.255.252
Branch1(config-if)#encapsulation ppp
Branch1(config-if)#ppp authentication pap
Branch1(config-if)#ppp pap sent-username Branch1 password cisco

Branch1(config-if)#no shutdown
Branch1(config-if)#exit
Branch1(config)#router eigrp 1
Branch1(config-router)#network 192.168.1.0 0.0.0.255
Branch1(config-router)#network 10.1.1.0 0.0.0.3
Branch1(config-router)#exit
Branch1(config)#exit
Branch1#copy running-config startup-config

Central

Router>enable
Router#configure terminal
Router(Config)#hostname Central
Central(Config)#enable password cisco (Plain Text Password)
Central(config)#enable secret class (Encrypted Password)
Central(Config)#line console 0
Central(Config-line)#password cisco
Central(Config-line)#login
Central(Config-line)#exit
Central(Config)#line vty 0 4
Central(Config-line)#password cisco
Central(Config-line)#login
Central(Config-line)#exit
Central(Config)#username Branch1 password cisco
Central(Config)#username Branch3 password cisco

Central(config)#interface serial 0/0/0
Central(config-if)#ip address 10.1.1.2 255.255.255.252
Central(config-if)#encapsulation ppp
Central(config-if)#ppp authentication pap
Central(config-if)#ppp pap sent-username Central password cisco

Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#interface serial 0/0/1
Central(config-if)#ip address 10.2.2.2 255.255.255.252
Central(config-if)#encapsulation ppp
Central(config-if)#ppp authentication pap
Central(config-if)#ppp pap sent-username Central password cisco

Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#interface loopback 0
Central(config-if)#ip address 209.165.200.225 255.255.255.224
Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#router eigrp 1
Central(config-router)#network 10.1.1.0 0.0.0.3
Central(config-router)#network 10.2.2.0 0.0.0.3
Central(config-router)#network 209.165.200.224 0.0.0.3
Central(config-router)#exit
Central(config)#exit
Central#copy running-config startup-config

Branch3

Router>enable
Router#configure terminal
Router(Config)#hostname Branch3
Branch3(Config)#enable password cisco (Plain Text Password)
Branch3(config)#enable secret class (Encrypted Password)
Branch3(Config)#line console 0
Branch3(Config-line)#password cisco
Branch3(Config-line)#login
Branch3(Config-line)#exit
Branch3(Config)#line vty 0 4
Branch3(Config-line)#password cisco
Branch3(Config-line)#login
Branch3(Config-line)#exit
Branch3(Config)#username Central password cisco
Branch3(config)#interface gigabiteathernet 0/1
Branch3(config-if)#ip address 192.168.3.1 255.255.255.0
Branch3(config-if)#no shutdown
Branch3(config-if)#exit
Branch3(config)#interface serial 0/0/1
Branch3(config-if)#ip address 10.2.2.1 255.255.255.252
Branch3(config-if)#encapsulation ppp
Branch3(config-if)#ppp authentication pap
Branch3(config-if)#ppp pap sent-username Branch3 password cisco

Branch3(config-if)#no shutdown
Branch3(config-if)#exit
Branch3(config)#router eigrp 1
Branch3(config-router)#network 192.168.3.0 0.0.0.255
Branch3(config-router)#network 10.2.2.0 0.0.0.3
Branch3(config-router)#exit
Branch3(config)#exit
Branch3#copy running-config startup-config

Configuration of CHAP

 PPP
PPP IP Table

Branch1

Router>enable
Router#configure terminal
Router(Config)#hostname Branch1
Branch1(Config)#enable password cisco (Plain Text Password)
Branch1(config)#enable secret class (Encrypted Password)
Branch1(Config)#line console 0
Branch1(Config-line)#password cisco
Branch1(Config-line)#login
Branch1(Config-line)#exit
Branch1(Config)#line vty 0 4
Branch1(Config-line)#password cisco
Branch1(Config-line)#login
Branch1(Config-line)#exit
Branch1(Config)#username Central password cisco
Branch1(config)#interface gigabiteathernet 0/1
Branch1(config-if)#ip address 192.168.1.1 255.255.255.0
Branch1(config-if)#no shutdown
Branch1(config-if)#exit
Branch1(config)#interface serial 0/0/0
Branch1(config-if)#ip address 10.1.1.1 255.255.255.252
Branch1(config-if)#encapsulation ppp
Branch1(config-if)#ppp authentication chap

Branch1(config-if)#no shutdown
Branch1(config-if)#exit
Branch1(config)#router eigrp 1
Branch1(config-router)#network 192.168.1.0 0.0.0.255
Branch1(config-router)#network 10.1.1.0 0.0.0.3
Branch1(config-router)#exit
Branch1(config)#exit
Branch1#copy running-config startup-config

Central

Router>enable
Router#configure terminal
Router(Config)#hostname Central
Central(Config)#enable password cisco (Plain Text Password)
Central(config)#enable secret class (Encrypted Password)
Central(Config)#line console 0
Central(Config-line)#password cisco
Central(Config-line)#login
Central(Config-line)#exit
Central(Config)#line vty 0 4
Central(Config-line)#password cisco
Central(Config-line)#login
Central(Config-line)#exit
Central(Config)#username Branch1 password cisco
Central(Config)#username Branch3 password cisco

Central(config)#interface serial 0/0/0
Central(config-if)#ip address 10.1.1.2 255.255.255.252
Central(config-if)#encapsulation ppp
Central(config-if)#ppp authentication chap

Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#interface serial 0/0/1
Central(config-if)#ip address 10.2.2.2 255.255.255.252
Central(config-if)#encapsulation ppp
Central(config-if)#ppp authentication chap

Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#interface loopback 0
Central(config-if)#ip address 209.165.200.225 255.255.255.224
Central(config-if)#no shutdown
Central(config-if)#exit
Central(config)#router eigrp 1
Central(config-router)#network 10.1.1.0 0.0.0.3
Central(config-router)#network 10.2.2.0 0.0.0.3
Central(config-router)#network 209.165.200.224 0.0.0.3
Central(config-router)#exit
Central(config)#exit
Central#copy running-config startup-config

Branch3

Router>enable
Router#configure terminal
Router(Config)#hostname Branch3
Branch3(Config)#enable password cisco (Plain Text Password)
Branch3(config)#enable secret class (Encrypted Password)
Branch3(Config)#line console 0
Branch3(Config-line)#password cisco
Branch3(Config-line)#login
Branch3(Config-line)#exit
Branch3(Config)#line vty 0 4
Branch3(Config-line)#password cisco
Branch3(Config-line)#login
Branch3(Config-line)#exit
Branch3(Config)#username Central password cisco
Branch3(config)#interface gigabiteathernet 0/1
Branch3(config-if)#ip address 192.168.3.1 255.255.255.0
Branch3(config-if)#no shutdown
Branch3(config-if)#exit
Branch3(config)#interface serial 0/0/1
Branch3(config-if)#ip address 10.2.2.1 255.255.255.252
Branch3(config-if)#encapsulation ppp
Branch3(config-if)#ppp authentication chap

Branch3(config-if)#no shutdown
Branch3(config-if)#exit
Branch3(config)#router eigrp 1
Branch3(config-router)#network 192.168.3.0 0.0.0.255
Branch3(config-router)#network 10.2.2.0 0.0.0.3
Branch3(config-router)#exit
Branch3(config)#exit
Branch3#copy running-config startup-config

2 comments: